Scion iM Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #1 ·
I bought a front &rear turn signal LED that plug and play and have a built in resister by Alla Lighting had them for a year now they work great. I recently bought a sequential strip of lights to replace the stock 194 bulb and lens in the mirrors .So the new LED strip mounts where the old lens was and plugs into the existing plug ,but now the turn signals are Hyper Flashing !!! Do I need a bigger relay flasher ?? IM lost any advice would be great....Sept.2019 Matt
 

·
Registered
Joined
·
73 Posts
Usually when someone swaps in LED for a turn signal and it blinks faster than normal, there isn't enough resistance to allow the flasher to work properly. You mention the first bulbs had a built in resistor - did the newer ones also have one built in - or were they just LED strips?
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #3 ·
Usually when someone swaps in LED for a turn signal and it blinks faster than normal, there isn't enough resistance to allow the flasher to work properly. You mention the first bulbs had a built in resistor - did the newer ones also have one built in - or were they just LED strips?
Just strips that someone suggested for the mirrors that fit his iM and are working fine from eBay I bought the same style / part number .I haven’t had an issue with the Alla front & rear sets with built in resistors till I tried to hook up the newer mirrors LEDs with no resistors they just plug into the original turn signal plug in mirror .When I put the old mirror lights in with the Allas front & rear they work fine .
 
1 - 3 of 3 Posts
Top